Author Topic: รบกวนพี่ๆ ช่วยผม set AC servo Panasonic MSDA043A1A กับ MACH3  (Read 352 times)

0 Members and 1 Guest are viewing this topic.

Offline pn13075

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 0
  • Posts: 6
คู่มือครับ http://www.deltaelektronik.dk/media/3287/minas_a_e.pdf

วิธีการต่อครับ http://www.mechatronics4u.com/th/articles/116406

262dc16c864b7d9ed6ce417ee91356fd.jpg" border="0

3a46ad0c3edea6d0e6c34d2f5d986b93.jpg" border="0

7e8df06b6fbd12aae2b62d6aaca48e92.jpg" border="0

ผมลองเซ็ต เป็น Position แล้วครับ แล้วก็ลองต่อ กับ interface ใช้กับมาค 3 แต่ปรากฏว่า พอส่งสัญญาณไปแล้ว ไม่หมุนครับ ผมคาดว่าน่าจะต่อ ตรง interface ผิด หรือไม่ก็เซ็ตค่าผิดครับ รบกวนด้วยนะครับพี่ๆ ขอบคุณครับ :)

Offline jck2127

  • Sr. Member
  • ****
  • Thank You
  • -Given: 131
  • -Receive: 403
  • Posts: 279
รบกวนขอดู Break out board หน่อยว่าเป็นแบบไหน
การต่อสาย CN ให้ต่อตามนี้นะครับ
ไฟลบ (0V) pin 33, 29, 9, 8, 41
ไฟบวก (+24V) pin 7
แค่นี้ก็ใช่ได้แล้วครับ
แล้วที่ตัวที่สำคัญ คือ พารามิเตอร์ที่ Pr2 = 0 และ Pr42 = 3
J-ArtTech by Jatuphol / Tel : 085-7000704 / Line ID : jck2127
www.facebook.com/J.ArtTech

Offline pn13075

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 0
  • Posts: 6
z3kVK9.jpg" border="0

เป็นตัว 4-axis interface ครับผม
ผมลองต่อ step เป็น 4 , Dir เป็น 6 ครับ
5v+ เป็น 3 กับ 5 ครับ รบกวนพี่ด้วยนะครับ ผมไม่ทราบว่าต่อถูกต้องหรือไม่
ส่วน ไฟลบ เดี๋ยวผมลอง ต่อนะครับ ตอนแรกผมต่อแต่ 41 กับ 29 ไว้ แต่ พอ ต่อ 29 แล้ว ขึ้น( err 15)
ครับผม
ปล.ผมอาจจะเข้ามาอัพเดตให้พี่ทราบอีกรอบ นานหน่อยนะครับ ช่วงนี้ผมติดสอบครับ ขอบคุณครับพี่ :D

Offline jck2127

  • Sr. Member
  • ****
  • Thank You
  • -Given: 131
  • -Receive: 403
  • Posts: 279
ตัวนี้น่าจะเหมือนของบอร์ด RNR จะเป็นการต่อแบบ open collector
โดยให้ puls1(pin3) มัดรวมกับ sign1(pin5) แล้วไปต่อกับ 5V
ส่วน puls2(pin4) ต่อกับ XP และ sign2(pin6) ต่อกับ XD (สมมุติว่าต่อกับแกน X)
ถ้าไม่เข้าใจก็โทรมาได้ 0857000704
J-ArtTech by Jatuphol / Tel : 085-7000704 / Line ID : jck2127
www.facebook.com/J.ArtTech

Offline pn13075

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 0
  • Posts: 6
เมื่อสักครู่ลองต่อดู ปรากฏว่าหมุน ได้แล้วครับ แต่ เกิดปัญหาเรื่อง err15 ฟ้องที่หน้าจอครับ ตอนใส่ไฟ 29 แต่ตอนที่ลอง เมื่อสักครู p____0 เปลี่ยนเป็น P____1 แล้วพอใส่สัญญาณ จากมาค 3 เข้าไป หมุนเเล้วครับ แต่ได้ครั้งเดียวครับ ครั้งต่อๆไป ขึ้น err15 ตลอดเลยครับ เมื่อใส่ ไฟ 29 เข้าไป 

สามารถเป็นไปได้หรือไม่หรอครับ ที่เซนเซอร์วัด อุณหภูมิ รวน
ขอบคุณพี่มากครับ  :D

Offline jck2127

  • Sr. Member
  • ****
  • Thank You
  • -Given: 131
  • -Receive: 403
  • Posts: 279
err15 คือการ alarm อุณหภูมิของไดร์ว หรือ over load
ซึ่งอาจเกิดจาก ตั้ง torque ไว้ต่ำ หรือ ตั้งค่า accelertion/deacceletion ไว้สูงมากเกินไป
แนะนำให้เคลียร์พารามิเตอร์ก่อน แล้วตั้งค่า defult ตามคู่มือ
จากนั้น ให้ตั้งค่าพารามิเตอร์ตามนี้
Pr2 = 0
Pr42 = 3
Pr5E = 300
แล้วลองรันดู ถ้าไม่ได้ให้ไปดูที่ไดร์วว่าพัดลมหมุนหรือไม่
หรืออาจจะเป็นไปได้ว่าเซ็นเซอร์อุณหภูมิเสีย
J-ArtTech by Jatuphol / Tel : 085-7000704 / Line ID : jck2127
www.facebook.com/J.ArtTech

Offline pn13075

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 0
  • Posts: 6
 เมื่อสักครู่ ผมลองเซ็ทค่า pr60 ปรากฏว่าอาการ error15 หายไปแล้วครับ จากนั้นก็ต่อ เข้า มาค3 ปรากฏว่า รันได้แล้วครับ ขอบคุณมากครับพี่ :D

Offline pn13075

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 0
  • Posts: 6
พี่ครับ ผมจะเพิ่มสปีดต้องไปเซทที่ตัวไหนหรอครับ ผมอ่านคู่มือแล้ว งงๆครับ ขอบคุณครับพี่ ตอนนี้วิ่งที่ 1000Rpmครับ

Offline jck2127

  • Sr. Member
  • ****
  • Thank You
  • -Given: 131
  • -Receive: 403
  • Posts: 279
ตั้งค่าที่ Pr 62 default คือ 1000 rpm
แต่ความเร็วเราตั้งค่าที่ Mach3 ได้ ตัวอย่างเช่น
บอลสกรูพิท 5 มม. แล้วมอเตอร์หมุนได้ 1000 rpm
แสดงว่าจะเคลื่อนที่ได้เร็วสุด 5000 mm./min.
มอเตอร์จะหมุนตามคำสั่งของ Mach3 ฉะนั้นเราตั้งที่ Pr 62 ให้มากไว้ก่อนได้
ถ้ามอเตอร์ตัวนี้เป็น Low initia ก็ตั้งไว้ที่ 3000 rpm ได้เลย

การตั้งต่า Pr 60 แล้ว error15 หายไป แสดงว่าได้ไม่ได้ทำ Auto tune หรือป่าว
เพราะถ้าทำ Auto tune มอเตอร์จะแข็งขึ้น ทำให้หลุดตำแหน่งได้ยากขึ้น
อันนี้ถ้าอธิบายคงพิมพ์ลำบาก โทรมาปรึกษาล่ะกัน
J-ArtTech by Jatuphol / Tel : 085-7000704 / Line ID : jck2127
www.facebook.com/J.ArtTech

Offline pn13075

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 0
  • Posts: 6
ขอบคุณครับพี่ ถ้าไม่ได้คำแนะนำจากพี่ผมคงเซ็ตไม่ได้
zDAtSR.jpg" border="0

ผมไปเซตค่า pr4A เป็น 4 ครับ ได้ตามที่ต้องการเลยครับ ไว้ผมทำเครื่องเสร็จแล้วผมเอามาแบ่งปั่นนะครับ(นานหน่อยครับผมยังเรียนอยู่เลย555555 น่าจะเป็นปีครับ)
ตอนแรกกะไว้ว่าจะทำเครื่องกลึง แต่ หัวเกียร์ดันเป็น 1:50 ครับ (ตอนซื้อไม่รู้) เลยว่าจะเอาไว้ทำตัว cnc 5 แกนครับ เป็นโต๊ะหมุน 0-180องศาครับ ขอบคุณพี่อีกครั้งนะครับ